Adobe potwierdza błąd w PDF

Przedstawiciele koncernu Adobe przyznali, że w zabezpieczeniach aplikacji Adobe Acrobat oraz Adobe Reader znajduje się krytyczny błąd umożliwiający skuteczne zaatakowanie komputera pracującego pod kontrolą Windows XP. Firma nie przygotowała na razie uaktualnienia rozwiązującego problem.

Przypomnijmy: o wykryciu takiej luki poinformował w połowie września brytyjski specjalista ds. zabezpieczeń Petko Petkov - wykrył on nieznany wcześniej błąd w zabezpieczeniach oprogramowanie Adobe. Luka pozwala na stworzenie pliku PDF, którego uruchomienie spowoduje zainfekowanie systemu złośliwym kodem. Petkov nie podał szczegółowych informacji na ten temat - zapowiedział, że udostępni je dopiero, gdy Adobe przygotuje odpowiednie uaktualnienie. Szerzej na ten temat pisaliśmy w tekście "Petkov znajduje lukę w PDF".

Przedstawiciele Adobe do niedawna nie komentowali tych doniesień - dopiero kilka dni temu potwierdzili, że w ich oprogramowaniu znajduje się krytyczna luka. Firma na razie nie udostępniła użytkownikom uaktualnienia rozwiązującego problem. Zamiast tego na jej stronach internetowych pojawiła się szczegółowa instrukcja, dzięki której użytkownicy mogą zmodyfikować ustawienia systemu - tak, by nie był on podatny na atak. Wymaga to m.in. wprowadzenia zmian do rejestru systemowego.

Wiadomo już, że problem jest związany z znacznikiem "mailto", który może w tym przypadku posłużyć do wprowadzenia do systemu niebezpiecznego kodu. Problem dotyczy na pewno Adobe Readera 8.1 oraz Adobe Acrobata 8.1, a także Adobe 3D (przedstawiciele Adobe zapowiedzieli już, że aplikacje te zostaną wkrótce uaktualnione).

Użytkownikom, którzy nie zdecydują się na wprowadzenie do systemu zalecanych modyfikacji, Adobe zaleca ostrożność w postępowaniu z plikami PDF pochodzącymi z nieznanego źródła (np. załączonych do wiadomości e-mail wysłanych przez nieznanych nadawców).

Z analiz specjalistów z Adobe wynika, że na atak narażeni są jedynie użytkownicy wymienionych powyżej aplikacji oraz systemu Windows XP z przeglądarką Internet Explorer (również w wersji 7). Osoby korzystające z Windows Vista są bezpieczne - mechanizmy zabezpieczające tego systemu uniemożliwiają wykorzystanie luki w PDF do zaatakowania komputera.

Więcej informacji o problemie oraz metodach zabezpieczenia systemu znaleźć można na stronie Adobe.


Zobacz również