Google: groźna luka w wyszukiwarce

Eksperci z firmy Watchfire wykryli poważny błąd w zabezpieczeniach aplikacji Google Desktop, służącej m.in. do wyszukiwania danych na dysku komputera. Luka umożliwia nieautoryzowane uruchomienie niebezpiecznego kodu. Firma Google udostępniła już uaktualnienie rozwiązujące problem.

Błąd wykryty został na początku stycznia, jednak przedstawiciele Watchfire czekali z opublikowaniem informacji na ten temat do momentu przygotowania przez Google poprawki. Uaktualnienie jest już dystrybuowane za pośrednictwem systemu automatycznej aktualizacji Google Desktop - wolna od błędu jest wersja 5.0.701.30540 i późniejsze. Przedstawiciele Google poinformowali też, że w nowych wydaniach GD nie tylko usunięto błąd wykryty przez Watchfire, ale także dodano nowe zabezpieczenia, które chronić mają użytkowników przed podobnymi zagrożeniami.

Problem związany był z jednym z parametrów, który wykorzystywany jest w opcji zaawansowanego wyszukiwania dostępnej w Google Desktop. Eksperci z Watchfire wykryli, że ów parametr może w odpowiednich okolicznościach zostać wykorzystany do nieautoryzowanego uruchomienia niebezpiecznego skryptu JavaScript.

Więcej informacji oraz najnowszą wersję programu Google Desktop znaleźć można na stronie Desktop.google.com.


Zobacz również