Dziurawa i niebezpieczna Opera 8.54

Wbrew powszechnej opinii nie tylko użytkownicy Internet Explorera narażeni są na ataki cyberprzestępców. Świadczy o tym błąd, który właśnie został wykryty w przeglądarce Opera. Umożliwia on uruchomienie dowolnego kodu na atakowanym komputerze.

Wcześniejsze wersje przeglądarki Opera zawierają błąd związany z przetwarzaniem plików graficznych JPEG. W przypadku, gdy we właściwościach pliku podane są zbyt duże wartości wysokości i szerokości obrazka następuje przepełnienie bufora, co napastnik wykorzystać może do uruchomienia dowolnego kodu i w efekcie przejęcia całkowitej kontroli nad komputerem. Problem występuje w Operze 8.54 i być może w jej wcześniejszych wersjach. Na razie, specjaliści radzą, aby miłośnicy norweskiej przeglądarki zainstalowali jej najnowszą wersję. Operę 9 do pobrania, wolną od opisywanego błędu, jak również opis jej najważniejszych funkcjonalności znajdziecie w artykule Opera 9 - finalna polska wersja do pobrania.