Vista SP1 nie chce się zainstalować lub nie pojawia się w Windows Update, czyli problematyczne sterowniki

W momencie udostępnienia pakietu Service Pack 1 do Visty Microsoft opublikował też artykuł mówiący o tym, w jakich wypadkach SP1 nie pojawi się na witrynie Windows Update. Myślę, że najciekawszy jego fragment dotyczy niekompatybilnych sterowników - które, jak się okazuje, udało się zidentyfikować.

Jeśli więc nie widzicie SP1 nawet po zastosowaniu tej porady, prawdopodobnie w Waszym komputerze znajduje się przynajmniej jedno z tych urządzeń:

Karty dźwiękowe

-- Realtek AC'97 - sterownik Alcxwdm.sys w wersji 6.0.1.6242 lub wcześniejszej albo Alcwdm64.sys w wersji 6.0.1.6242 lub wcześniejszej (Vista x64).

-- SigmaTel - sterownik Sthda.sys w wersji 5.10.5762.0 lub wcześniejszej albo Sthda64.sys w wersji 5.10.5762.0 lub wcześniejszej (Vista x64).

-- SigmaTel - sterownik Stwrt.sys w wersji 6.10.5511.0 lub wcześniejszej albo Stwrt64.sys w wersji 6.10.5511.0 lub wcześniejszej (Vista x64).

-- Creative Audigy - sterownik Ctaud2k.sys w wersji 6.0.1.1242 lub wcześniejszej albo wszystkie wersje P17.sys.

-- Conexant HD Audio - sterownik Chdart.sys w wersji 4.32.0.0 lub wcześniejszej albo Chdart64.sys w wersji 4.32.0.0 lub wcześniejszej (Vista x64)

Urządzenia biometryczne

-- AuthenTec Fingerprint Sensor - sterownik Atswpdrv.sys w wersji 7.7.1.7 lub wcześniejszej.

-- UPEK Fingerprint Sensor (często pojawiający się w notebookach IBM/Lenovo) - sterownik Tcusb.sys w wersji 1.9.2.99 lub wcześniejszej.

Karty graficzne/chipsety graficzne

-- Chipsety Intela - sterownik Igdkmd32.sys w wersjach między (i włączając) 7.14.10.1322 a 7.14.10.1403 albo Igdkmd64.sys w wersjach między 7.14.10.1322 a 7.14.10.1403.

Inne urządzenia i aplikacje

-- Texas Instruments Smart Card Controller - sterownik GTIPCI21.sys w wersji 1.0.1.19 lub wcześniejszej.

-- Sierra Wireless AirCard 580 z aplikacją Watcher.exe - wersja 3.4.0.9 lub wcześniejsza.

-- Symantec Endpoint Protection, Symantec Network Access Control clients - sterownik Wgx.sys w wersji 11.0.1000.1091 lub wcześniejszej albo Wgx64.sys wersji 11.0.1000.1091 lub wcześniejszej.

UWAGA

Jeśli macie którekolwiek z wymienionych urządzeń, uczciwie odradzam instalowanie SP1 już teraz, przed uaktualnieniem driverów. Niebieskie ekrany błędu macie niemal gwarantowane.

Kompletny artykuł na ten temat znajdziecie na witrynie Microsoftu.