Firefox 4: jak odblokować starsze rozszerzenia

Najnowszy Firefox to jedna z najchętniej pobieranych aplikacji w historii internetu. Pomimo wielu zalet, nowa przeglądarka Mozilli dostarcza nam też kilku problemów. Jednym z nich są niedziałające add-ony z wersji Firefox 3.6.

Firefox 4 przynosi z sobą wiele zmian, takich jak: odnowiony interfejs użytkownika, lepszy silnik JavaScript, synchronizacja zakładek i opcja "Nie śledź". To wszystko świetne, ale kiedy rozszerzenia przydatne w biurze nie chcą się włączać, trudno zachwycać się nowinkami.

Na szczęście: istnieje sposób, aby wyłączyć sprawdzanie zgodności, funkcję przeglądarki Firefox 4, która blokuje starsze rozszerzenia.

Tutaj małe ostrzeżenie. Choć większość add-onów będzie działać dobrze (w naszych testach 100 proc.), część niekompatybilnych rozszerzeń faktycznie może źle wpływać na wydajność przeglądarki, a nawet całkiem ją wyłączyć. Próbujcie więc na własne ryzyko!

Hokus pokus Firefox 4: niedziałające add-ony

1. Otwórz nową kartę, wpisz: about:config w pasku adresu i wciśnij Enter.

2. Prawym klawiszem myszy kliknij w oknie głównym, a następnie wybierz: Dodaj ustawienie typu > Wartość logiczna (Boolean).

3. Kopiuj i wklej następującą nazwę nowego ustawienia: extensions.checkCompatibility.4.0.

4. Kliknij przycisk OK, a następnie ustaw wartość False (ustawiona domyślnie).

5. Zamknij i uruchom ponownie przeglądarkę.

Teraz pełny dostęp do wszystkich dodatków i wtyczek powinien zostać przywrócony. Można to sprawdzić wybierając: Narzędzia > Dodatki.