Tekst i funkcje w jednej komórce

Czy wiesz, że w jednej komórce można umieścić jednocześnie tekst i funkcję?


Czy wiesz, że w jednej komórce można umieścić jednocześnie tekst i funkcję? Na przykład: komórka A10 zawiera liczbę 1500. Jeżeli w innej komórce wpiszesz ="Suma: "&A10, to otrzymasz w efekcie napis "Suma: 1500". Operator & służy do połączenia dwóch składników zawartości komórki.

Tekst i funkcje w jednej komórce

Formuła w komórce A1 łączy wyświetlanie tekstu i sformatowanej daty i czasu.

Jeżeli chcemy osiągnąć bardziej wyszukane efekty, możemy połączyć więcej elementów, np. =Suma: "&A10"zł". Można także skorzystać z funkcji TEKST(), która umożliwia bardziej zaawansowane formatowanie napisów.

Przykładem nieco bardziej skomplikowanego złożenia może być tekst:

="Data: "&TEKST(TERAZ();"d mmmm rrrr, g:mm")

Oprócz złożenia tekstu i formuły za pomocą & wykorzystano także funkcję TEKST() do sformatowania daty i czasu, otrzymanych od funkcji TERAZ().

Przykładowy efekt działania takiej formuły przedstawia ilustracja.

Przydatne skróty

Jak szybko zaznaczyć całą tabelę w Excelu? Nie chodzi nam o zaznaczenie całego arkusza (można to osiągnąć za pomocą skrótu [Ctrl+A]), ale o wybranie wszystkich elementów pojedynczej tabeli (która może się składać z np. 3 kolumn i 10 wierszy).

Wystarczy ustawić się gdziekolwiek w środku tabeli i użyć kombinacji [Ctrl+*] (* na klawiaturze numerycznej) lub [Ctrl+Shift+8].

Za pomocą skrótu klawiszowego możemy także ukryć wiersz lub kolumnę. Aby ukryć bieżącą kolumnę, użyj kombinacji [Ctrl+0]. Do ukrycia bieżącego wiersza służy [Ctrl+9].

Ukrytą kolumnę lub wiersz możemy przywrócić do normalnej edycji za pomocą skrótów [Ctrl+Shift+0] i [Ctrl+Shift+9] (odpowiednio dla wiersza i kolumny).

Wychodzimy na brzeg

Czy wiesz, że do nawigacji po arkuszu możesz wykorzystać nawet obramowanie aktywnej komórki?

Jeżeli klikniesz dwukrotnie jeden z brzegów aktywnej komórki (zaznaczonej pogrubionym obramowaniem), to przesuniesz się do odpowiedniej krawędzi tabeli, np. dwukrotne kliknięcie górnego brzegu komórki spowoduje przesunięcie do pierwszego wiersza tabeli (przez tabelę rozumiemy spójny obszar arkusza - bez pustych pól).

Jeżeli przytrzymasz jednocześnie wciśnięty klawisz [Shift], to zaznaczone zostaną komórki znajdujące się pomiędzy bieżącą pozycją a odpowiednim brzegiem tabeli.

Na żywo

Tekst i funkcje w jednej komórce

Łącze rysunku pozwala przygotować transmisję "na żywo" dowolnego obszaru arkusza.

Excel (wersja 5 i nowsze) udostępnia narzędzie pozwalające utworzyć rysunek, będący niejako transmisją "na żywo" wybranego obszaru arkusza.

Zaznaczmy wybrany obszar i skopiujmy go do Schowka ([Ctrl+C] lub EdycjaéKopiuj). Teraz trzymając wciśnięty klawisz [Shift] należy wybrać EdycjaéWklej łącze rysunku. Utworzony rysunek możemy umieścić w dowolnym miejscu arkusza.

Wszystkie zmiany zachodzące w oryginalnym obszarze odzwierciedlone będą na rysunku. Sposób ten znakomicie ułatwia tworzenie np. zestawienia kilku wybranych miejsc arkusza na pojedynczej stronie.

Warunkowe obliczanie średniej

Do obliczenia średniej z danego zakresu komórek najłatwiej jest użyć funkcji =ŚREDNIA(). Czasami jednak potrzebujemy bardziej wyszukanego sposobu obliczania średniej.

Może zaistnieć sytuacja, w której np. przy liczeniu średniej nie chcemy brać pod uwagę najwyższej i najniższej wartości. W takim przypadku nie stosujemy funkcji =ŚREDNIA(), ale używamy nieco innej formuły ("dane" oznaczają obszar, z którego liczymy średnią:

=(SUMA(dane)-MIN(dane))&ILE.NIEPUSTYCH(dane)

Kopiowanie wartości w liście

Tekst i funkcje w jednej komórce

Aby poprawnie posortować listę, należy skopiować wartości w pierwszej kolumnie.

Często zdarza się, że pojedyncza wartość w liście odnosi się do kilku wierszy arkusza, np. nazwisko osoby odnoszące się do kilku wierszy zawierających płace za poszczególne miesiące (patrz ilustracja). Jeżeli spróbujemy posortować takie dane względem pierwszej kolumny, to większość pozycji (tych odpowiadających pustemu polu w pierwszej kolumnie) znajdzie się na końcu listy.

Aby prawidłowo posortować taką listę, należy w jakiś sposób skopiować dane w pierwszej kolumnie, tak by zlikwidować puste miejsca. Gdy tabela jest mała, można to zrobić ręcznie. Jednak w przypadku większej ilości danych można pokusić się o znalezienie sposobu na automatyczne kopiowanie wartości.

  1. Zaznacz odpowiedni zakres w pierwszej kolumnie (A3:A18 w naszym przypadku).

  2. Za pomocą klawisza [F5] otwórz okno Przejdź do.

  3. ##Kliknij przycisk Specjalnie.

  4. Wybierz opcję Puste i kliknij przycisk OK.

  5. Wpisz =, a następnie adres komórki, od której zaczynają się dane w pierwszej kolumnie (w przedstawianym przypadku będzie to=A3). Wciśnij [Ctrl+Enter].

  6. Teraz możesz już posortować dane (Dane Sortuj).