Usuwanie problemów z wykresem liniowym

Wstawianie wykresów w Excelu jest bardzo proste. Wystarczy przejść do Wstaw/Wykres i postępować zgodnie ze wskazówkami kreatora wykresów. Często zdarza się jednak, że nie uzyskujemy zamierzonych efektów.


Wstawianie wykresów w Excelu jest bardzo proste. Wystarczy przejść do Wstaw/Wykres i postępować zgodnie ze wskazówkami kreatora wykresów. Często zdarza się jednak, że nie uzyskujemy zamierzonych efektów.

Jednym z typowych przykładów może być sytuacja, gdy chcemy utworzyć wykres liniowy, a podany zakres danych zawiera puste komórki. Na wykresie zobaczymy wtedy kilka przerywanych krótkich linii lub poszczególne punkty.

Jak się okazuje, Excel nie potrafi sobie poradzić z pustymi komórkami - używa sposobu domyślnego, czyli pomija wątpliwe odcinki.

Możemy zaradzić temu na dwa sposoby. Należy przejść do Narzędzia | Opcje do karty Wykres i zaznaczyć jedną z dwóch opcji w polu Kreśl puste komórki jako. Jeżeli wybierzemy opcję Zera, puste komórki zostaną potraktowane jako wartości zerowe, natomiast gdy zaznaczymy pozycję Interpolowane, brakujące wartości zostaną tak dobrane, aby otrzymać ciągłą, gładką linię wykresu.

Zaawansowane sumowanie wybranych wartości

Dwa sposoby na uporanie się z pustymi wartościami przy wykresach liniowych: wstawienie wartości zerowej oraz interpolacja.

Dwa sposoby na uporanie się z pustymi wartościami przy wykresach liniowych: wstawienie wartości zerowej oraz interpolacja.

Gdy przygotowujemy większe zestawienia, często zachodzi potrzeba wybrania i zsumowania kilku wartości: największych bądź najmniejszych. Dostęp do największej wartości w wybranym zakresie danych umożliwia funkcja MAX.K(). Funkcja ta przyjmuje dwa argumenty. Pierwszy z nich to zakres danych, wśród których zostanie wybrana k-ta największa wartość, drugi to numer pozycji w podanym zakresie (licząc od największej). Tak więc np. formuła =MAX.K(A1:A200;4) zwróci czwartą z kolei największą wartość w zakresie A1:A200.

Jeżeli chcemy obliczyć sumę kilku (np. trzech) największych wartości w tablicy, możemy użyć formuły:

=MAX.K(A1:A200,1) + MAX.K(A1;A200,2) + MAX.K(A1:A200,3)

lub w bardziej skondensowanej postaci: ####

=SUMA(MAX.K(A1:A200;{1;2;3}))

Dwa sposoby na uporanie się z pustymi wartościami przy wykresach liniowych: wstawienie wartości zerowej oraz interpolacja.

Dwa sposoby na uporanie się z pustymi wartościami przy wykresach liniowych: wstawienie wartości zerowej oraz interpolacja.

Warto zwrócić uwagę na sposób wykorzystania nawiasów klamrowych {}, dzięki któremu formuła ma tak zwartą postać (po wpisaniu formuły powinniśmy użyć skrótu [Ctrl Shift Enter], aby tablica {1;2;3} została poprawnie zinterpretowana).

Jeżeli chcemy zsumować większą liczbę pozycji (np. 40), wykorzystanie podanych wyżej formuł jest kłopotliwe. Możemy zastosować bardziej ogólną wersję wyrażenia:

=SUMA(MAX.K(A1:A14;WIERSZ(A1:A10)))

Musimy jednak uruchomić tę formułę jako formułę tablicową - po jej wpisaniu używamy kombinacji [Ctrl Shift Enter] zamiast zwykłego [Enter]. Wtedy funkcja WIERSZ() zwróci 10 wartości (od 1 do 10), które posłużą jako zbiór argumentów dla funkcji MAX.K().

W podobny sposób możemy wybierać i sumować wartości najmniejsze Đ zamiast funkcji MAX.K() używamy wtedy funkcji MIN.K().

Oszczędność przede wszystkim

Podobno 80 procent tworzonych arkuszy zawiera tylko jedną małą tabelę (jakieś 5 na 5 komórek). Szkoda marnować niewykorzystaną powierzchnię, nie mamy jednak wpływu na rozmiar arkusza. Możemy natomiast zmniejszyć liczbę arkuszy w nowym skoroszycie Excela (standardowo tworzone są trzy nowe arkusze). Wystarczy w tym celu przejść do Narzędzia | Opcja do karty Ogólne i zmniejszyć liczbę w polu Liczba arkuszy w nowym skoroszycie.

Wklejanie wartości w komórki

Aby ograniczyć liczbę arkuszy w nowo tworzonym skoroszycie, należy zmienić ustawienia w Narzędzia | Opcje | Ogólne.

Aby ograniczyć liczbę arkuszy w nowo tworzonym skoroszycie, należy zmienić ustawienia w Narzędzia | Opcje | Ogólne.

O różnych sposobach edycji komórek w Excelu można rozprawiać bez końca. Teraz wspomnimy tylko o mało znanej, a przydatnej metodzie. Po skopiowa-niu zawartości komórki (komórek) do Schowka, możemy wkleić je w inne miejsce, wybierając docelową komórkę i naciskając klawisz [Enter]. Jest to metoda znacznie szybsza niż klikanie przycisku na pasku narzędzi i trochę wygodniejsza niż używanie skrótu [Ctrl V]. Użycie klawisza [Enter] opróżnia jednak zawartość Schowka (w Excelu 2000 usuwany jest bieżący element Schowka), tak więc jeśli chcemy skopiowaną wartość wkleić w kilka komórek, lepiej użyć skrótu [Ctrl V].

Możemy także jednym ruchem wkleić wartość ze Schowka do zakresu komórek. W tym celu należy skopiować najpierw komórkę do Schowka [Ctrl C], zaznaczyć kilka komórek i nacisnąć klawisz [Enter]. Warto pamiętać, że podczas zaznaczania komórek można przytrzymać wciśnięty klawisz [Ctrl], co pozwoli zaznaczyć komórki w różnych punktach arkusza (nie tylko zwykły prostokątny obszar).